in

Greasemonkey 2.0: ¿Actualizar o esperar?

Greasemonkey es “la” herramienta definitiva para modificar el aspecto de una página o servicio web, agregar funciones o eliminarlas. Recientemente, sus desarrolladores publicaron la versión 2.0 en el repositorio de extensiones de Firefox, pero con este nuevo build existe la posibilidad de que muchos scripts pierdan compatibilidad. ¿Hacemos la prueba en nombre de la ciencia…?

Hay usuarios que sencillamente no pueden abrir una sola pestaña de Firefox sin Greasemonkey ejecutándose en el fondo. Casi todo sitio tiene espacio para recibir alguna modificación extra, y en general los scripts hacen un excelente trabajo. Actualmente, estoy usando a YouTube Center, que altera varios aspectos del portal de vídeos, incorpora funciones y deshabilita otras como la reproducción DASH, un protocolo que tiende a arruinar la barra de tracking en cada vídeo, anular la precarga de vídeos (sí YouTube, queremos eso) y generar problemas de buffering. De más está decirlo, YouTube Center es mi primera recomendación para cualquier usuario de Greasemonkey, que el martes pasado alcanzó su versión 2.0. Mozilla tiene a la extensión en proceso de revisión, y en estos instantes la versión 2.0 sólo está disponible a través de la sección “Versions”, con una instalación manual.

Greasemonkey 2.0
Decidí instalarlo, pero…

El sitio oficial de Greasemonkey (enlace más abajo) nos explica que uno de los cambios en la nueva versión modifica el comportamiento de la extensión a la hora de establecer un modo llamado “grant” que los scripts utilizan para acceder a ciertos API. En ediciones previas, Greasemonkey recurría a un proceso de detección automática, pero a partir de ahora, los scripts deben especificar el “grant”. Esto sólo afecta a scripts nuevos, o que hayan sido actualizados recientemente. El otro cambio de alto perfil está en el sandbox privilegiado de Greasemonkey, que recibió actualizaciones en respuesta a los ajustes sobre la función unsafeWindow en el SDK de extensiones de Firefox. Todo esto apunta a mejorar tanto la seguridad como la estabilidad del navegador y de Greasemonkey.

Greasemonkey
… nada. El script que utilizo se lleva de los pelos con Greasemonkey 2.0.

Si un script establece desde el comienzo su “grant”, estos cambios no lo afectarán, y lo mismo se aplica en caso de que no tenga interacción con unsafeWindow. De lo contrario, es muy probable que Greasemonkey 2.0 quiebre la compatibilidad con ese script. Decidí poner esto a prueba con el antes mencionado YouTube Center. Desde hace un tiempo utilizo los builds de desarrollo, que reciben varias correcciones en un mismo día, y el veredicto es… catastrófico. Greasemonkey 2.0 se convierte en artillería antiaérea frente al build 320 de YouTube Center, y lo derriba sin piedad. Por lo tanto, si la nueva versión quiebra al único script que utilizo, no quiero imaginar lo que hará a aquellos usuarios con media docena o más. Recomiendo esperar hasta que los desarrolladores de scripts se adapten a la nueva versión.

Reportar

What do you think?

Veterano

Written by Lisandro Pardo

Moderador de ComunidadUsuario VerificadoVotadorAutor de contenidoCreador de GaleríasCreador de Listas

Comments

Leave a Reply

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

Loading…

0

Comentarios

0 comentarios

Fire Phone: Amazon quiere guerra con su smartphone

Photoshop Mix: Adobe presenta un nuevo editor para iPad